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Rich Media Guidelines

Thsdocument outlines TruEffect-s specifications
media controls. These specs allow for the control and tracking of intra -banner activity,

banner resizing, and click -throughs. Our controls are straightforward and require no

knowl edge of custom APl -s or complicated JavasS:t

Flash functionality with a simple text file to identify actions and control HTML
container sizing. If yo u have questions, please contact your client services
representative.

Adding Click -through Tracking Code to a Flash Banner

To insert a click-through into a Flash banner:

In order for a Flash banner to contain click-through tracking capabilities, clickable
elements are usually assigned to buttons. A button is a special type of symbol that
contains 4 frames. Each frame represents one of the following "states" of the button: Up,
Over, Down, or Hit. These states determine how the button will visually behave when the
user rolls their mouse over it or clicks on it.

To create a new button:

7 Select Insert > New Symbol, or press Control-F8 (Windows) or Command-F8
(Macintosh).

U Note: In Macromedia Flash 3 and earlier, deselect everything on the
stage and choose Insert > Create Symbol

1 Inthe Symbol Properties dialog box, enter a name for the new button symbol and
choose Button as the Behavior option. Click OK.

9 Flash will switch to symbol-editing mode. The Timeline header changes to display
four consecutive frames labeled Up, Over, Down, and Hit. The first frame, Up, is a
blank keyframe.

9 To create the image for the button's Up state, you can use the drawing tools,
import a graphic, or place an instance of another symbol on the Stage. You can use
either a movie clip or a graphic symbol in a button, but you cannot use another
button in a button. To create an animated button, use movie clip symbols.

9 Select the second frame, labeled Over, and choose Insert > Keyframe. The button
image from the first frame will appear on the Stage.

9 Change the button image for the Over state. Repeat steps 4 and 5 for the Down
frame and the Hit frame.

a Note: The Hit frame is not visible on the Stage on playback, but it
defines the area of the button that responds when clicked. Make sure that
the graphic for the Hit frame is a solid area large enough to encompass all
the graphic elements of the Up, Down, and Over frames. It can also be
larger than the visible button. If you do not specify a hit frame, the objects
in the Up state are used as the hit frame.
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After defining the images of the four button states, choose Edit > Edit Movie to exit
Symbol Edit mode.

Open the Library window by choosing Window > Library. Locate the button in the
Library window and then drag the button symbol out of the Library onto the Stage.
This creates an instance of the button in the movie. For information on assigning
actions to the button instance refer to the documentation below for the version of
Flash that you are using.

To assign a simple action to a button (Flash 5 or later):

)l
il
)l

In Edit Movie mode, select the button instance created in Step 7 above.
Choose Window > Actions to open the Actions panel.
In the Toolbox list on the left side of the panel, click the Basic Actions category to
display the basic actions.
To assign an action, do one of the following:

U Double-click an action in the Basics Actions category.

U Drag an action from the Basic Actions category on the left to the Actions

list on the right side of the panel.

U Click the Add (+) button and choose an action from the pop-up menu.
If the chosen action has any associated parameters, those parameters will appear
in the Parameter pane at the bottom of the Actions panel. (If the Parameter pane is
not visible, click the small triangle in the lower right corner of the panel.) Choose
or type the parameters appropriate for that action. For example, the getURL action
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clickTAG:

shown below contains three parameters: URL, Window, Variables, and an option
for Expression.

9 The clickTAG is the tracking code assigned by the ad serving network to an
individual ad. The clickTAG allows the network to register where the ad was
displayed when it was clicked on. This click through data is reported to the ad server
so you can determine the effectiveness of your campaign.

9 The clickTARGET allows the ad serving network to change the target window for the
click-through action of the ad banner, without the need for you to compile a separate
SWF for every possible target window.

1 The code below will allow ad serving networks to dynamically assign a clickTAG to

the ad

u

c:

In this example, a getURL action is being assigned to a button that will navigate
the browser to the destination specified by the clickTAG. The "getURL (clickTAG,
clickTARGET)" statement appends the variable data passed in via the OBJECT
EMBED tag and navigates the browser to that location. It is the tracking code
assigned by the ad serving network, which allows them to register a user's click on
that advertisement.

<EMBED
sre="ad_banner_example.swf?clickTARGET=_blank&clickTAG=http%3A//www.de
stination.com/">

The code below will allow ad serving networks to dynamically assign a elickTAG
to their ad:

on (release) §

getURL (clickTAG, clickTARGET);

§
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Notes:

9 A banner that needs to track multiple click-throughs should use clickTAG1,
clickTAG2, clickTAG3, ete, instead of the clickTAG parameter used with single click
banners (although clickTAG may be used instead of clickTAG1 for the first click-

through).

1 Beginning with Flash v. 7, parameter names are case sensitive. This means that
clickTag is not the same as clickTAG.
1 Below is a workflow diagram of how the variable is passed from the Flash
advertisement to the ad serving network, and then redirected to the URL.
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HTML Web page with Macromedia Flash advertisement

N

E’% Macromedia Flash advertisement with variable

Tracking HREF passed into Macromedia Flash via HTML
<0BJECT: and <EMBED?> tags

{EMBED SREC=bannerswi?Click TAG=
http:fadnetwork.com/tracking?
n.destinationUEL.com

¢ hittp:

~__ Macromedia Flash advertisement navigates browser to
z E value passed in

SWEF Instrumentation  to track user interaction
and control expandable creative

Overview

1 Rich Media instrumentation consists of a few ActionSecript calls to resize the banner

and to measure user interaction.
U flash. external.Externallnterface.call (_ ro ot.Expand _panel );
f lash. external.Externallnterface.call(_root.Collapse_panel);
f lash. external.Externallnterface.call(_root.Measure_this,
fAEvent_Name 0);

9 For each rich media creative, one ZIP file is delivered to TruEffect™ and that file
contains all of the assets required to render the creative. At a minimum, this means
one SWF file and its corresponding animated GIF (for browsers unable to render the
SWF banner.)

9 For expandable banners, the zip must also contain a control file which specifies sizes
for the HTML DIV containers which will host the banner when it is served. This file

must be named sizes.txt.
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Action Tracking

9 TruEffect provides a single polymorphic JavaSeript function which can be called to

measure any event of interest, such as:
U Flash. external.Externallnterface.call(_root.Measure _this,
fiRollover HDTV 0);
U Flash. external.Externallnterface.call(_root.Measure_this,
fiPlay Gamed);
U Flash. external.Externallnterface.call(_root.Measure_this,
fiPause _Video 0);
.
9 Please note that this method requires the Event_Name to be passed as an additional
argument in the call. [whitespace and special chars will be stripped from the

Event_Name during processing]

Sizes.txt:

1 Two tag/values pairs are required in the “sizes.txt” file:
U Collapse_panel - the normal size of the banner
U Expand_panel - the expanded size of the banner
9 These two tags are needed only in the event the banner is expandable. If the banner is
static, then width and height settings assigned by the TruConnect user interface are
used and “sizes.txt” is unnecessary.
9 The values associated with “Collapse_panel” and “Expand_panel” are used to create
DIV containers for the ad placement.
1 Formatting
U Mustinclude “Collapse_Panel” and “Expand_panel” tags with “WXH”
values
U  Banner size (in pixels) is specified as width-by-height, e.g. 468X60 or
250X250
U Eachtag/value pair must appear on its own line, blank lines are ignored
U Whitespace is used to delimit the tag and value, extra whitespace is
ignored
U If duplicate tags are encountered, only the first will be used

9 Sample sizes.txt
U Collapse_panel 550X160
U Expand_panel 800X600
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More Details

1 A single creative may be composed of one or more SWF’s.
1 An expandable creative consists of two SWF’s:
0 A parent SWF which is displayed in the Collapse panel DIV
0 A child SWF which is displayed in the Expanded panel DIV
1 Both DIV’s are played in the ad slot, but CSS styles are toggled such that only one is
visible at a time.
1 Both SWPF’sin an expandable unit will receive the same set of FlashVars
1 Mouseover and mouseout events should be handled by ActionScript. Web sites have
specific rules on how these events affect expandable banners. The most common
requirement is that the banner should collapse on a mouseout event.
T If multiple SWFs are used in a creative, then clickTAG(s) should be used in any/all
SWF’s which perform clickthroughs.

TruEffect Y Specific Specifications

1 TruEffect™ recognizes Flash versions 4 through 10, and ActionSecript versions 2
through 3.

1 TruEffect™ extracts clickTAG and clickTARGET references from each SWF binary
and uses them to dynamically generate a FlashVars parameter for that banner.

1 Calls to getURL() and navigateToURL() can be used interchangeably in your
ActionScript code for clickthroughs to the advertiser's landing page.

1 A banner that needs to track multiple clickthroughs should use clickTAG1,
clickTAGz2, clickTAGS3, etc, instead of the plain clickTAG parameter used with
single-click banners (although clickTAG may be used instead of clickTAG1 for the
first clickthrough).

9 A banner may use the variables IPcity or IPdma to manage dynamic content that
generates text with respect to geographic location.

1 A banner that calls loadMovie() or loadVariables(), should do so using absolute
URLs, which are generated by combining the value of the swIPATH parameter with
the relative URL of the component file, e.g. loadVariables(swfPATH+"rates.txt"). If the
component is not hosted by TruEffect, then use the absolute URL for the file on the
foreign host, but make sure that the host has implemented an appropriate
"crossdomain.xml” policy.

1 Note that NetStream.play() can safely be called with a relative URL. In this case, the
swfPATH parameter can still be used, but it's not strictly necessary.

1 Beginning with Flash version 7, variable names are case-sensitive. This means that
clickTag is not the same as clickTAG. This is a function of the version of the SWF file
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itself, not the version of the plug-in on the user's browser. TruEffect attempts to
identify clickTAG variables within the SWF binary and provide a case-appropriate
version in the FlashVars PARAM. This approach works as long as you use consistent
spelling for every clickTAG variable in your ActionScript code.

1 TruEffect™ also offers a mechanism whereby each banner can specify the desired
spelling of every elickTAG variable by including a special TXT file in the ZIP archive.
See clickTAG Overrides

1 Inbanners containing multiple movies/layers, you may need to fully qualify each
variable name, e.g. clickTAG would become _root.clickTAG (or _levelo.clickTAG).

M TruEffect™
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